Tuesday, October 31, 2006

My problem with Internet Explorer 7.0 solved!!

I was facing some problems while using IE 7.0. I’m using this from last almost 6+ months from its Beta 1 version.

First time I come to know the problem while trying to browsing INETA APAC site. Whenever I try to access this website http://apac.ineta.org I face one problem, there is menu on that site I was unable to use that as it not showing me that menu and showing ‘error in loading’ message in status bar. I was thinking it may be because of the beta and may be solved in final IE but on 20th October when I installed IE 7.0 full then also it showing me same problem. I really feel very bad as I was not able to access INETA site from my laptop.

Second problem was with Windows Live mail beta i.e. my Hotmail/MSN e-mail account. When I type www.hotmail.com it shows me the login page and after entering the login name and password it starts redirecting to other pages, in few seconds it shows “Done” in status bar of IE and the main thing is that there is nothing on page, page was blank. Since I’m using outlook for my mail I didn’t care much about this problem. And also I found one solution if I need to check my hotmail mail on web. I login to Windows Live messenger in that there is a ‘Windows Live today’ page which normally opens as soon as you login. In that if I click on any mail my Windows Live mail gets open without a problem. So I didn’t think to the mail problem.

Third problem was with www.mail.com . The site was not able to open. One of my friends who use mail.com as his primary mail address faces this problem when he tried to access it from my pc. Since I don’t have account there I didn’t care to solve this problem also.

But now the forth problem was with my own web application… so I have no option to think on that and try to solve. Till now I was developing and testing that on my local host. And that was working fine so no issue. Now application is almost over and I hosted that to my web server for live testing. And the problem starts from here…. Some of features are not available or fails to run. Initially I thought that there must be some problem with IIS so check that… install all updates etc. but it still give me problem. But that same application was working well if I access that from other windows XP PCs with IE6.0 or other browsers. Last 2-3 days I was trying to solve this. I was also thinking there might be some bug in application I also check my code If I can solve that… I tried to solve that everyway I can but failed. So decided to post this to some forum or to mvp mailing list so that some one may help me so I was planning to post that on today evening. But I got solution for that on today morning….

Actually today I was really in a very bad mood in morning … since I heart one of my best friends and I was filling like very guilty for that and because of that I was not in a good mood to do some thing new. So in office I was just playing with that application. (Good na ! I have my won company else can I do this? playing ???) Don’t know how one point comes in my mind that same applications runs on my laptop if I can access it from local host and why not from my web server over the Internet. What is the difference between these 2 in case of accessing it from IE 7.0 and then I notice one thing on the status bar on IE. For local lost it showing as “Trusted site” and for web server over internet it shows “Internet”. I said lets try I added my web application URL as a “Trusted site” in IE7.0. And here it goes… everything is working fine. So I just tried this for all 3 problem mention above and all problems are solved. So the problem was with security of IE 7.0 and I‘m so stupid that I was searching that everywhere in the code, IIS etc.

So if you face the problem like this and thinks… not just think if you are sure about that site then you can add that site as trusted site to IE 7.0 but do care while adding since adding to trusted site give more access for scripts and active controls on your machine. I use this since the site is developed by me and I trust my self other Ineta and Hotmail …I can trust them blindly for mail.com I just test that and removed since I don’t know about that site.

No comments: