Wednesday, November 10, 2010

Could not load type System.ServiceModel.Activation.HttpModule


Just faced one problem with my Windows Server 2008 R2 server while configuring my Silverlight WCF application for demo…

my application was working fine on my localhost and it fail to start when I uploaded to my demo server, and I got following error message…

“Could not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089'.”

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

This error can occur when IIS is installed after installing .NET Framework 4, or if the 3.0 version of the WCF Http Activation module is installed after installing IIS and .NET Framework 4.

simplest solution to resolve this issue, run the following from command line:

aspnet_regiis.exe /iru

you can locate aspnet_regiis.exe at

  • %windir%\Microsoft.NET\Framework\v4.0.30319
  • %windir%\Microsoft.NET\Framework64\v4.0.30319 (on a 64-bit machine)

Monday, November 01, 2010

PUG Live Webcasts - An exclusive series of webcasts by Pune User Group

We are pleased to announce the launch of PUG Live Webcasts, an initiative by PUG team through which you will enjoy series of Webcasts on various Microsoft technologies. We are starting with Visual Studio 2010 and Windows Phone 7 Development series; very soon we will be coming up with SharePoint 2010, Silverlight and many more technologies.

for more details visit